Garmin ANT Stick

General discussion about the Bushido Ergo/VR trainer

Moderators: mcorn, Tacx Moderator, malfukt, Nasz

Garmin Ant Stick ans TTS 3.6

Postby JohnE » Sun Nov 27, 2011 3:26 pm

Does anybody know if the new TTS 3.6 support the Garmin Ant Stick and drivers better than the 3.5 version - is the Ant version 2 drivers included in the TTS 3.6 or shall we still strugle with copying them manuel ?
JohnE
 
Posts: 7
Joined: Wed Nov 24, 2010 10:06 am

Postby UniMatrixOne » Sun Nov 27, 2011 9:23 pm

I don't think anything has changed as far as the ANT support is concerned. I still experience lockups / crashes at startup and shutdown. Have to start TTS at least two times for a successful connection.

No problems during training however.

Hope TTS4 will support the generation 2 stick.
UniMatrixOne
 
Posts: 42
Joined: Fri Nov 05, 2010 3:21 pm
Location: Netherlands, NH

Re: Garmin Ant Stick ans TTS 3.6

Postby ms6073 » Wed Nov 30, 2011 8:04 pm

JohnE wrote:is the Ant version 2 drivers included in the TTS 3.6 or shall we still strugle with copying them manuel ?

TTS 3.6 has drivers only for the orginal ANT1USB stick. I was using the ANT2USB stick and driver with 3.5 but had to revert back to the ANT1USB drivers after upgrading as TTS 3.6 crashed shortly after displaying the news every single time. If someone has been able to get the version 2 drivers working with TTS 3.6, it would be nice if they would reply/post the solution on how they got them to work with TTS 3.6!
Michael - Cogito Ergo Sum
__0
_ \ |_
(O)/ (O)
User avatar
ms6073
 
Posts: 837
Joined: Sat Oct 07, 2006 9:06 pm
Location: USA, Houston, TX

Re: Garmin Ant Stick ans TTS 3.6

Postby UniMatrixOne » Wed Nov 30, 2011 9:07 pm

ms6073 wrote:
JohnE wrote:is the Ant version 2 drivers included in the TTS 3.6 or shall we still strugle with copying them manuel ?

TTS 3.6 has drivers only for the orginal ANT1USB stick. I was using the ANT2USB stick and driver with 3.5 but had to revert back to the ANT1USB drivers after upgrading as TTS 3.6 crashed shortly after displaying the news every single time. If someone has been able to get the version 2 drivers working with TTS 3.6, it would be nice if they would reply/post the solution on how they got them to work with TTS 3.6!


Hi Michael, try disabling the news or if you can't because of crashing, first start without internet connection. There has been an issue with the news that was also discussed on this forum that might be the problem and not the drivers.

I'm using TTS 3.6 with the ANT2 drivers copied as described earlier in this topic.
UniMatrixOne
 
Posts: 42
Joined: Fri Nov 05, 2010 3:21 pm
Location: Netherlands, NH

Postby ms6073 » Wed Nov 30, 2011 9:19 pm

I don't think it was an issue with the news as I did not upgrade until after Tacx resolved that problem. Currently the ANT1 ANT2 drivers are really not an issue as I only use TTS for sending Catalyst trainings to Bushido and an occasion RLT. Of course it would be nice to use the ANT2 stick as it has less lag when training with TTS but I suspect we will have to wait for TTS 4.0 before Tacx offers those drivers.
Michael - Cogito Ergo Sum
__0
_ \ |_
(O)/ (O)
User avatar
ms6073
 
Posts: 837
Joined: Sat Oct 07, 2006 9:06 pm
Location: USA, Houston, TX

Postby JPansy » Thu Dec 01, 2011 7:40 am

I have the same issue with 3.6 and my Garmin ANT2 Stick. Crashes shortly after displaying news. If I remove the stick or the (copied) ant.dll's, the software works - but of course the bushido not ... W7/32bit. TTS2 works with the new dll's as well as older versions of 3.x did. Am using USB drivers that came with the TTS2 software (never installed any 3rd party drivers like Garmins or the ones from thisisant.com)

Looks to me as if 3.6 does not work with the newer thisisant.dll's which are necessary for ANT2 sticks.

:cry:
"alls you can do is alls you can do" - http://blog.jpansy.at
JPansy
 
Posts: 92
Joined: Sat Oct 30, 2010 1:34 am

Postby UniMatrixOne » Thu Dec 01, 2011 8:07 am

Mine crashes too, but after 1 or 2 restarts of tts3.6 it succeeds in finding the Vortex computer and brake.

I haven't enabled the news again so maybe you guys can also try disabling it?

Still would like to see support for ANT2!
UniMatrixOne
 
Posts: 42
Joined: Fri Nov 05, 2010 3:21 pm
Location: Netherlands, NH

Postby JPansy » Fri Dec 02, 2011 6:26 pm

Did a bit more testing yesterday, with different drivers, starting TTS with and without stick, with & without Bushido head unit turned on etc.. Final conclusion: I could not find a working combination of TTS 3.6 (in Bushido Mode) & Garmin ANT2 Stick & Win7/32bit

So i sent a mail to tacx support and asked them to forward the problems to the dev team.

Today i got this - somewhat cryptic - response back:
"Yes

But TTS3.7 to 3.8 will
Those will be official TTS2 support"

Which i interpret as: "TTS 3.7 or 3.8 will have official ANT2 support" :D
"alls you can do is alls you can do" - http://blog.jpansy.at
JPansy
 
Posts: 92
Joined: Sat Oct 30, 2010 1:34 am

Postby UniMatrixOne » Fri Dec 02, 2011 8:47 pm

Would be great!

However, if they keep the new releases up (3.7, 3.8 ) they only have 3.9 left before 4.0 :wink:
UniMatrixOne
 
Posts: 42
Joined: Fri Nov 05, 2010 3:21 pm
Location: Netherlands, NH

Postby bertcord » Sun Jan 08, 2012 10:58 pm

tried all of the workarounds here...it crashes everytime for me.

no clue why...fresh install of windows7 x64. using the drivers from windows update and copied the 4 files over from thisisant site.

I have the USB2 stick...and I just won an auction on ebay for a used forerunner 50...my thought is that since this watch is old it should included the USB1 stick...

I also have sent an email to support. First I was told

" The bushido only Works with ANT1 stick. So im no sure what you have bought but if you do not have the T1990 Bushido upgrade package I cannot help you"

I then asked where I could get the USB1 stick and was told

"Maybe you can send an email to sales@tacx.nl to see if they can help you with this."

I sent sales an email but have not recevied a response.

I then asked support "When will TTS support the USB 2 ant+ stick?"

and was told...

"From TTS 3.7 (full version is there, update i hope this week to version 3.8)"

not really sure what that meens... but for now I will just wait. :cry:

Bert
bertcord
 
Posts: 2
Joined: Sun Jan 08, 2012 10:48 pm

Postby ms6073 » Mon Jan 09, 2012 11:21 pm

Sounds like since the Genius users are already using it, Tacx is planning to release TTS 3.7 to the rest of us in the comming week.
Michael - Cogito Ergo Sum
__0
_ \ |_
(O)/ (O)
User avatar
ms6073
 
Posts: 837
Joined: Sat Oct 07, 2006 9:06 pm
Location: USA, Houston, TX

Postby UniMatrixOne » Tue Jan 10, 2012 9:20 am

Fingers crossed :wink:

The last two months of winter training without glitches would be nice, allthough the winter over here doesn't amount to anything this year :D Just as well could have been riding outside on the road bike if it wasn't for the trainer tyre that doesn't allow this :wink:
UniMatrixOne
 
Posts: 42
Joined: Fri Nov 05, 2010 3:21 pm
Location: Netherlands, NH

Postby JPansy » Wed Jan 18, 2012 4:54 pm

Guys i have some really good news:

Yesterday, after reading this thread ( http://forum.tacx.com/viewtopic.php?t=1 ... df32937681 ), i became creative and tried to dowload http://www.tacxdata.com/files/patches/TTS3/TTS3700.exe . Well what should i say, a ~350MB file came in. :lol:

So i installed the patch and checked the DLLs: TTS 3.7 comes with the newest ant_dll's (Filesize is identical to the ones on the thisisant site).

Ok, so launched TTS3.7 and my bushido head unit was immediately found. The brake not.

So i closed TTS3.7 again, went on the head unit into settings -> brake and did a reconnect. Brake was reconnected. Then i launched TTS3.7 and the head unit and the brake were both found and connected.

Did a short 30min VR ride today and everything seemed to work smoothly. :D (Well as smoothly as it can be with a bushido - but that's another story ...)

However i was not able to import or export any rides to my head unit. Looks like the problem introduced in 3.5 (or 3.6) still persists. :(

At least i can now ride league rides (http://www.indoor-bike-league.de/) with TTS3 (supported from 3.6 onwards). Otherwise 3.3 was the best version for me so far, as my Garmin stick worked fine as well as import/export did.
"alls you can do is alls you can do" - http://blog.jpansy.at
JPansy
 
Posts: 92
Joined: Sat Oct 30, 2010 1:34 am

Postby kasters » Wed Jan 18, 2012 5:56 pm

Just for my understanding!
Tacx is using the old USB 1 ANT.
And now with the copy paste action you have the Tacx working on the new USB2 ANT?

Pleas let me know thanks :D
With Kind Regards,

Stefan

Tacx 4.9.2 & 3.12.0 + beta
Genius T2000, GE enabled
Bushido for tablet T2790

i7 4771 4e generation
16gb internal memory.
NVidia GTX 560 Ti 2Gb video card
100mb fiber internet, samsung 512 SSD drive
Windows 7 SP1 64Bits OS
User avatar
kasters
 
Posts: 848
Joined: Mon Jan 25, 2010 8:04 pm
Location: Netherlands

Postby JPansy » Wed Jan 18, 2012 6:37 pm

Yes,i'm using a Garmin ANT2 stick.

What i'm saying is that ...

... TTS3.0-TTS3.3/3.4 worked somewhat by copying the DLLs (crashed sometimes)

... TTS3.5&3.6 did not work because it always crashed when using the copied DLLs. And without copied DLLs ANT2 sticks don't work.

... TTS3.7 works out of the box, does not require any DLL copying and does not crash anymore.
"alls you can do is alls you can do" - http://blog.jpansy.at
JPansy
 
Posts: 92
Joined: Sat Oct 30, 2010 1:34 am

Postby mcorn » Wed Jan 18, 2012 7:29 pm

I think that TTS3.7 has the same new Genius and Ant+ drivers that TTS4beta is using
mcorn
Moderator
 
Posts: 11437
Joined: Fri Nov 24, 2006 8:55 pm
Location: USA, Seattle, Washington

Postby UniMatrixOne » Thu Jan 19, 2012 3:32 pm

Good news JPansy !

I'm also using an ANT2 stick with the copied DLLs at the moment.

I'm curious: what did you do with the copied DLLs prior to the upgrade? Especially the ANT_WrappedLib.dll that's not present in a standard TTS install.

My idea was to remove the copied ones and put back the original Tacx DLLs before the upgrade.
UniMatrixOne
 
Posts: 42
Joined: Fri Nov 05, 2010 3:21 pm
Location: Netherlands, NH

Postby ms6073 » Thu Jan 19, 2012 4:05 pm

UniMatrixOne wrote:I'm curious: what did you do with the copied DLLs prior to the upgrade? Especially the ANT_WrappedLib.dll that's not present in a standard TTS install.
I have installed the 3.7 update as well - simply right click the link to the TTS3700.exe (also posted above) and save to local hdd. To install the update, unplug USB Ant stick from machine and then double click the update and follow the prompts to complete the install. Not sure if this is still necessary with 3.7, but after the update and I first started the Bushido handlebar controller then went through Settings -> Brake -> Connect routine before starting/connecting to 3.7. I would also recommend using freeride for 5-10 minutes to warmup the tire then perform a motorbrake calibration before connecting to 3.7 the first time.
Michael - Cogito Ergo Sum
__0
_ \ |_
(O)/ (O)
User avatar
ms6073
 
Posts: 837
Joined: Sat Oct 07, 2006 9:06 pm
Location: USA, Houston, TX

Postby JPansy » Thu Jan 19, 2012 4:40 pm

UniMatrixOne wrote:Good news JPansy !

I'm also using an ANT2 stick with the copied DLLs at the moment.

I'm curious: what did you do with the copied DLLs prior to the upgrade? Especially the ANT_WrappedLib.dll that's not present in a standard TTS install.

My idea was to remove the copied ones and put back the original Tacx DLLs before the upgrade.


The update overwrites the copied ones. Simply leave them there.
"alls you can do is alls you can do" - http://blog.jpansy.at
JPansy
 
Posts: 92
Joined: Sat Oct 30, 2010 1:34 am

Postby hamsey » Thu Jan 19, 2012 6:39 pm

3.7 Do you have to go progressive 3.5 to 3.6 to 3.7? I am at 3.5 due to the problems I was having with 3.6. Would love to move to 3.7 and use my ant2 stick if I can find it. Only way to get 3.6 is through TTS that I know of. Downloading 3.7 as I write this.
Norm, Connecticut
Bushido 2011 W7 64 TTS3.13
hamsey
 
Posts: 224
Joined: Fri Jan 21, 2011 9:45 pm

PreviousNext

Return to Tacx Bushido/Vortex/Genius/Upgrade PC

Who is online

Users browsing this forum: No registered users and 1 guest