Tacx Genius Squeak & Slipping

General discussion about the ANT+ Trainers

Moderators: malfukt, mcorn, Tacx Moderator, Nasz

Post Reply
alastair825
Posts: 12
Joined: Tue Nov 16, 2010 6:57 pm

Tacx Genius Squeak & Slipping

Post by alastair825 » Mon Dec 03, 2012 12:53 am

Hi

I’m having trouble with my turbo trainer squeak and slipping, I have provided a link to a video to show this problem below

http://www.youtube.com/watch?v=AcBgiKCalFU

My current setting for the turbo trainer are tyre at 120 psi and set to 8.3 in tts4 with slot 2. This start to happen when I go over 5% - 6% incline.

I have recently bought the Lake District dvd and it is impossible complete with the tyre slipping and squeaking

Please can someone help?

Alastair

Howsteepisit
Posts: 567
Joined: Sat Dec 05, 2009 1:11 am
Location: Eugene Oregon, US

Post by Howsteepisit » Mon Dec 03, 2012 1:02 am

I never managed to get my Tacx tire to not slip right now I am using a worn ruffy tuffy tire at120 and getting no slip. Longevity is unknown
Howsteepisit
TTS2.06 TTS 3.10, TTS 4.3
Windows 7 Home Premium 64 bit
Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50GHz (4 CPUs), ~2.5GHz
Memory: 6144MB RAM
Galaxy nvidia GTX 550 TI 2 GB dedicated,
1920x1080 HDTV display

User avatar
malfukt
Moderator
Posts: 5507
Joined: Wed Feb 25, 2009 2:53 pm
Location: UK

Post by malfukt » Mon Dec 03, 2012 2:33 am

First try different tyre..
i7-950 Processor (4cores 3.06 GHz)
2xBIOS settings 1 overclocked to 4.3ghz
6G RAM dominator 1600Mhz
MSI NVIDIA 560 ti 1GB
CRUCIAL SSD
NEOx1 GENIUS. BUSHIDO smart
TTS beta vers 4.22.5 & TDA beta & TCA beta

alastair825
Posts: 12
Joined: Tue Nov 16, 2010 6:57 pm

Post by alastair825 » Mon Dec 03, 2012 8:49 am

Which tyre would you recommend I have the blue tacx one atm.

Tony Alaska USA
Posts: 499
Joined: Thu Dec 07, 2006 8:18 am
Location: USA, Anchorage Alaska USA

Post by Tony Alaska USA » Mon Dec 03, 2012 11:56 pm

alastair825
are you sure you have the motorbreak in the right slot? I know that for some this made a difference. I am almost sure I have mine in the recommended middle slot for a standard road bike.
Ride Hard or Go Home

alastair825
Posts: 12
Joined: Tue Nov 16, 2010 6:57 pm

Post by alastair825 » Tue Dec 04, 2012 9:17 pm

Hi

I have just checked and it is in slot 2, does anyone else have this problem when going up hill? would someone be able to film themselves going up a hill, for an example one in the Lake District DVD so I can hear the sounds their turbo trainner makes (Genius if possible)

Alastair

User avatar
malfukt
Moderator
Posts: 5507
Joined: Wed Feb 25, 2009 2:53 pm
Location: UK

Post by malfukt » Tue Dec 04, 2012 9:22 pm

I have been up that particular hill & many others with my GENIUS, no squeaks :roll:

I now use a Continental trainer tyre, i use to use the tacx trainer tyre, it did use to squeak very slightly when a lot of effort put in at very beginning of a ride (first couple of minutes, if i had`nt warmed it up).. :)
i7-950 Processor (4cores 3.06 GHz)
2xBIOS settings 1 overclocked to 4.3ghz
6G RAM dominator 1600Mhz
MSI NVIDIA 560 ti 1GB
CRUCIAL SSD
NEOx1 GENIUS. BUSHIDO smart
TTS beta vers 4.22.5 & TDA beta & TCA beta

alastair825
Posts: 12
Joined: Tue Nov 16, 2010 6:57 pm

Post by alastair825 » Tue Dec 04, 2012 9:28 pm

Hi malfukt, so yours sounds nothing like mine, is your continental tyre black, do you have any other idea what could fix the squeak?

Ali

Raikko
Posts: 6
Joined: Wed Sep 12, 2012 7:38 am

Post by Raikko » Wed Dec 12, 2012 10:14 am

with calibration value of 9 and 8 bars on tyre I haven't been able to get it slip once, not even in 16% hills which I drilled yesterday. I'm pretty sure it has something to do with the grip of the tyre? Mine is red vittoria training tyre if that helps at all, very good tyre, have had it for 3 years and still going strong.

Best Regards
Raikko

Blueberry
Posts: 502
Joined: Sun Dec 25, 2011 6:56 pm
Location: Northern Germany

Post by Blueberry » Wed Dec 12, 2012 2:09 pm

I got kind of a squeacking noise but no slippage on the Genius.

I use an old road tire and from time to time I rub the surface of the tire with degreaser to clean it and make it a little "sticky".

Calibration value is around 7.3 with 8bar tire pressure.

viner_james
Posts: 13
Joined: Sat Apr 09, 2011 4:18 pm

Re: Tacx Genius Squeak & Slipping

Post by viner_james » Thu Jun 14, 2018 7:00 pm

A little late to ask perhaps but I have the exact same problem. Changed the blue Tacx tyre to a continental GP4000 road tyre ... but pretty much the same problem. Did you resolve this and how?

frankhertz
Posts: 36
Joined: Sun Jun 16, 2013 4:02 pm
Location: Toronto, Canada

Re: Tacx Genius Squeak & Slipping

Post by frankhertz » Fri Jun 15, 2018 1:48 pm

I had a similar issue with a fortius trainer and was able to solve the problem by thoroughly cleaning the roller and the tire with 70% isopropyl alcohol (not rubbing alcohol) and keeping the pressure above 115 psi.

Harry

viner_james
Posts: 13
Joined: Sat Apr 09, 2011 4:18 pm

Re: Tacx Genius Squeak & Slipping

Post by viner_james » Fri Jun 15, 2018 2:12 pm

Ok - I’ll give it a go - many thanks :)

mcorn
Moderator
Posts: 7455
Joined: Fri Nov 24, 2006 8:55 pm
Location: USA, Bellingham, Washington

Re: Tacx Genius Squeak & Slipping

Post by mcorn » Fri Jun 15, 2018 4:05 pm

It is also possible that the noise is the stainless steel sleeve over the urethane roller is beginning to come loose. One symptom of that is the noise is worse when it is cold. Without hearing the noise, it is kind of a guess, but sleeve failures are quite common after a couple of years. There is a long "epoxy fix" thread on the forum on how to do a repair.

viner_james
Posts: 13
Joined: Sat Apr 09, 2011 4:18 pm

Re: Tacx Genius Squeak & Slipping

Post by viner_james » Sun Aug 19, 2018 10:08 pm

Just a follow up as the problem has been fixed. I recalibrated the brake and pumped up the tyre a bit, along with cleaning the roller as suggested - and all is silent again :)

I think the recalibration did the trick.

Thanks for the input guys.

Post Reply

Return to “Tacx Bushido/Vortex/Genius/Neo”

Who is online

Users browsing this forum: No registered users and 10 guests