TACX Neo

General discussion about the ANT+ Trainers

Moderators: mcorn, Tacx Moderator, malfukt, Nasz

Post Reply
Wightmagic
Posts: 4
Joined: Thu Nov 24, 2016 5:21 pm

TACX Neo

Post by Wightmagic » Wed Nov 22, 2017 6:36 pm

Hi.
I currently run a TACX Neo Turbo Trainer with TTS4 software. It has been running okay since i bought the Neo device 6 months ago , but just recently the TTS4 was playing up and after about 15-20 minutes it would stop working.
I sent a Report from the TACX support log , and they sent me details on how to remedy it , which so far it has , but it is early days.
But now i have another problem !!! , i run it with a NEO Steering tool , which has now stopped working ( although i do wonder why i bought it has it doesn't register me steering on the screen) and also the handlebar control does not stay on , i am really frustrated with it as i do train on this more than i go out due to work commitments.
Can someone please give me some advice on what to do , i am 52 years of age , and so i am not really astute when it comes to software and its accessories playing up.

Thank you in advance.

Ray.

ttelmah
Posts: 654
Joined: Thu Jul 14, 2011 3:13 pm
Location: UK

Re: TACX Neo

Post by ttelmah » Wed Nov 22, 2017 8:28 pm

Six months. Try replacing the batteries. Used heavily these will run down in only a couple of months. On my third set now, using good quality alkaline cells....

Wightmagic
Posts: 4
Joined: Thu Nov 24, 2016 5:21 pm

Re: TACX Neo

Post by Wightmagic » Mon Nov 27, 2017 1:35 pm

Thank you.
Have now tried that but it still did not work , have emailed TACX direct and they are going to send me a new one.

Thanks again.

Post Reply

Return to “Tacx Bushido/Vortex/Genius/Neo”

Who is online

Users browsing this forum: No registered users and 11 guests