New Utility app - fix for the Neo update customers

General discussion about the ANT+ Trainers

Moderators: malfukt, mcorn, Tacx Moderator, Nasz

Tacx support
Site Admin
Posts: 294
Joined: Tue May 12, 2009 3:05 pm

New Utility app - fix for the Neo update customers

Post by Tacx support » Sat Oct 24, 2015 7:17 pm

Hi

The New utility app is online (some already noticed this)


What to do
1. remove your old Utility app
2. then install the new utility app that is in the App store (version 1.2.14)
3. Go to devices - then select your trainer (or the name it finds)
4. Then go to Update and press UPDATE

when you are asked to turn off bluetooth, slide the bar (see pictures) and then turn Bluetooth off and wait 3 seconds and then turn it on. This is the best. use the slide bar of your iphone at the botton to turn BT on or off)

It could be that the app stops at 50%.
Then select Dashboard or wait and then go to update again and you can continue the update (or it is done again)
Then there is also a big change you do not need to turn Bluetooth on or off after the second session

If you still experience problems let us know or send a mail to support@tacx.com


IMPORTANT
make sure that OTHER Bluetooth connections are NOT turned on or DISCONNECTED.
This can cause problems during the update (the Bluetooth needs to be turned off and on and if you have other BT devices connected this could cause problems)

artur
Posts: 22
Joined: Mon Oct 12, 2015 4:08 am

Re: New Utility app - fix for the Neo update customers

Post by artur » Wed Oct 28, 2015 3:40 am

how about utility app for customers that don't use APPLE?

Tacx support
Site Admin
Posts: 294
Joined: Tue May 12, 2009 3:05 pm

Re: New Utility app - fix for the Neo update customers

Post by Tacx support » Wed Oct 28, 2015 8:29 am

We are working on this for Android, but this is not as easy.
We do have a Beta version, but had to take this offline.
As soon as we have a working version this will be online and we will make this public

psprigs
Posts: 5
Joined: Sat Oct 17, 2015 10:27 pm

Re: New Utility app - fix for the Neo update customers

Post by psprigs » Fri Nov 06, 2015 12:12 am

What is the newest version numbers at the moment?

artur
Posts: 22
Joined: Mon Oct 12, 2015 4:08 am

Re: New Utility app - fix for the Neo update customers

Post by artur » Sat Nov 07, 2015 1:19 pm

still nothing for the android users?

i find that the neo is keeping its last saved resistance and thus it differs until connected to the software

User avatar
ms6073
Posts: 1820
Joined: Sat Oct 07, 2006 9:06 pm
Location: USA, Houston, TX

Re: New Utility app - fix for the Neo update customers

Post by ms6073 » Sat Nov 07, 2015 5:07 pm

Not that this helps now, but when Wahoo introduced the Kickr, iOS devices was the only way to update and it was nearly a year before the introduction of an Android utility.
TTS 4.19.1 | T2800 NEO Smart [formerly Bushido & Fortius]
MSI GS70 Laptop | Windows 10 x64
Intel Core i7-4710HQ 2.40 GHz | 16 Gb DDR3 1600 MHz
GeForce GTX 870M | 256 GB SSD x 2 RAID 0 + 1 TB HDD
Samsung 32" LED TV

silus
Posts: 7
Joined: Sun Nov 01, 2015 5:04 pm

Re: New Utility app - fix for the Neo update customers

Post by silus » Sat Nov 07, 2015 6:12 pm

Tacx support wrote:Hi

The New utility app is online (some already noticed this)


What to do
1. remove your old Utility app
2. then install the new utility app that is in the App store (version 1.2.14)
3. Go to devices - then select your trainer (or the name it finds)
4. Then go to Update and press UPDATE

when you are asked to turn off bluetooth, slide the bar (see pictures) and then turn Bluetooth off and wait 3 seconds and then turn it on. This is the best. use the slide bar of your iphone at the botton to turn BT on or off)

It could be that the app stops at 50%.
Then select Dashboard or wait and then go to update again and you can continue the update (or it is done again)
Then there is also a big change you do not need to turn Bluetooth on or off after the second session

If you still experience problems let us know or send a mail to support@tacx.com


IMPORTANT
make sure that OTHER Bluetooth connections are NOT turned on or DISCONNECTED.
This can cause problems during the update (the Bluetooth needs to be turned off and on and if you have other BT devices connected this could cause problems)
Been doing this for hours, gets to 50% and asks to turn blue tooth off and on then disconnects. dashboard is showing DfuNrf not neo.

HELP!!!!

ckz
Posts: 3
Joined: Mon Nov 09, 2015 11:58 pm

Re: New Utility app - fix for the Neo update customers

Post by ckz » Tue Nov 10, 2015 12:06 am

Ok?!
And if iOS is easy then what problem will Android app have? Feels like we users are Beta testers - Again.

/Patrik

Jghazal
Posts: 9
Joined: Thu Nov 26, 2015 11:12 pm

Re: New Utility app - fix for the Neo update customers

Post by Jghazal » Tue Dec 01, 2015 10:04 pm

Yes, same here, not working and just got a new Neo in replacement of a wahoo...

SMC
Posts: 257
Joined: Sun Oct 23, 2011 1:49 am
Location: Toronto

Re: New Utility app - fix for the Neo update customers

Post by SMC » Tue Dec 01, 2015 10:24 pm

Jghazal wrote:Yes, same here, not working and just got a new Neo in replacement of a wahoo...

per support email I received there are issues with some trainers below 1000 serial number (which mine is) that will be resolved with an APP update this week.

This is for Android users.

Scott

artur
Posts: 22
Joined: Mon Oct 12, 2015 4:08 am

Re: New Utility app - fix for the Neo update customers

Post by artur » Tue Dec 08, 2015 6:46 am

hi i just upgraded my tacx neo to firmware 0.3.2 and suddenly the third party software (perfpro studio) i am running has problems controlling the trainer. Would you be able to tell me whether there are any differences in communication protocol that got introduced to new firmware -

Jghazal
Posts: 9
Joined: Thu Nov 26, 2015 11:12 pm

Re: New Utility app - fix for the Neo update customers

Post by Jghazal » Wed Dec 09, 2015 9:33 am

I am on IOS. I tried the update this past weekend and it worked. But I have a major power discrepancy (30w) between the app and true power from my power meter. I thought the Neo was within 2%, didn't need calibration and was accurate. Disappointed so far!

robp
Posts: 55
Joined: Wed Dec 22, 2010 2:28 pm

Re: New Utility app - fix for the Neo update customers

Post by robp » Fri Dec 11, 2015 3:40 pm

Jghazal wrote:I am on IOS. I tried the update this past weekend and it worked. But I have a major power discrepancy (30w) between the app and true power from my power meter. I thought the Neo was within 2%, didn't need calibration and was accurate. Disappointed so far!
Yeah ditto. Mine was basically identical to my quarq (not necessarily instantaneously equal, but same averages for even very short periods), but now Neo reading 20 or 30w higher in TTS4. Zwift seems to still be bang on equal though. :?

ChrisCYWG
Posts: 66
Joined: Wed Feb 08, 2006 1:51 am

Re: New Utility app - fix for the Neo update customers

Post by ChrisCYWG » Sun Dec 13, 2015 6:01 am

Which firmware version are you running.. Im a little lost in this thread now.. the original thread had to do with the original firmware way back in October that didnt install properly and your neo became a doorstop.. that was promptly fixed.. now I understand there is a newer firmware version out that is on IOS only???

What does it do?? Someone else said there is an android version coming and some trainers under SN 1000 having an issue? I have 945 and the November firmware installed and its been running fine..

artur
Posts: 22
Joined: Mon Oct 12, 2015 4:08 am

Re: New Utility app - fix for the Neo update customers

Post by artur » Mon Dec 14, 2015 6:53 am

i started to have problems with the perpro after the installation of new firmware -

youngguan
Posts: 1
Joined: Wed Jul 20, 2016 6:32 am

Re: New Utility app - fix for the Neo update customers

Post by youngguan » Wed Jul 20, 2016 6:54 am

silus wrote:
Tacx support wrote:Hi

The New utility app is online (some already noticed this)


What to do
1. remove your old Utility app
2. then install the new utility app that is in the App store (version 1.2.14)
3. Go to devices - then select your trainer (or the name it finds)
4. Then go to Update and press UPDATE

when you are asked to turn off bluetooth, slide the bar (see pictures) and then turn Bluetooth off and wait 3 seconds and then turn it on. This is the best. use the slide bar of your iphone at the botton to turn BT on or off)

It could be that the app stops at 50%.
Then select Dashboard or wait and then go to update again and you can continue the update (or it is done again)
Then there is also a big change you do not need to turn Bluetooth on or off after the second session

If you still experience problems let us know or send a mail to support@tacx.com


IMPORTANT
make sure that OTHER Bluetooth connections are NOT turned on or DISCONNECTED.
This can cause problems during the update (the Bluetooth needs to be turned off and on and if you have other BT devices connected this could cause problems)
Been doing this for hours, gets to 50% and asks to turn blue tooth off and on then disconnects. dashboard is showing DfuNrf not neo.

HELP!!!!
I have the same problem, after gets to 50%, updating stopped, and now I cannot connect neo anymore, cause the signals of Bluetooth and ant+ can not be searched by any devices. The neo totally hurts me

User avatar
ms6073
Posts: 1820
Joined: Sat Oct 07, 2006 9:06 pm
Location: USA, Houston, TX

Re: New Utility app - fix for the Neo update customers

Post by ms6073 » Wed Jul 20, 2016 1:06 pm

If you still experience problems let us know or send a mail to support@tacx.com
TTS 4.19.1 | T2800 NEO Smart [formerly Bushido & Fortius]
MSI GS70 Laptop | Windows 10 x64
Intel Core i7-4710HQ 2.40 GHz | 16 Gb DDR3 1600 MHz
GeForce GTX 870M | 256 GB SSD x 2 RAID 0 + 1 TB HDD
Samsung 32" LED TV

samppa
Posts: 3
Joined: Mon Sep 19, 2016 8:50 am

Re: New Utility app - fix for the Neo update customers

Post by samppa » Mon Sep 19, 2016 9:00 am

Tacx Utility 1.3.8 does not work on Android.

Shows current version: 0.5.1 / 0.2.1 / 0.4.2 and offers latest version 0.5.1 / 0.2.1 / 0.6.11.

When I click update it reboots and gives "Uploading failed" error message.

Trainer does not work with current versions, sensors are giving random values, power varies 0-13W and goes to 0 after a while. RPM stays at 0 and speed 0-2 km/m.

Should I return my brand new Neo to shop or is there a workaround?

Tacx support
Site Admin
Posts: 294
Joined: Tue May 12, 2009 3:05 pm

Re: New Utility app - fix for the Neo update customers

Post by Tacx support » Mon Sep 19, 2016 9:13 am

you also send message on Neo group correct. Did you try with the iPad ?

samppa
Posts: 3
Joined: Mon Sep 19, 2016 8:50 am

Re: New Utility app - fix for the Neo update customers

Post by samppa » Mon Sep 19, 2016 11:44 am

Unfortunately I have no iOS devices available, cannot try.

Post Reply

Return to “Tacx Bushido/Vortex/Genius/Neo”

Who is online

Users browsing this forum: No registered users and 19 guests