Problems with Streetview on GPS-rides since 15th February

Moderators: mcorn, Tacx Moderator, malfukt, Tacx support, Fortius Magical Man

Locked
mcinner
Posts: 167
Joined: Fri Nov 20, 2015 10:19 pm

Re: Problems with Streetview on GPS-rides since 15th February

Post by mcinner » Wed Apr 05, 2017 1:28 pm

My God, dear me...
What I'm reading here is no good news at all.
At that moment I don't have the guts to risk the upgrade... :oops:

Patdu16
Posts: 9
Joined: Sun Mar 01, 2015 11:37 am

Re: Problems with Streetview on GPS-rides since 15th February

Post by Patdu16 » Wed Apr 05, 2017 2:01 pm

Hello,

I upgrade to 4.22.3 yesterday and streetview is back.

Unfortunately google 3d did not return.

I have not contacted Tacx support, how can i do to got my 2 Tacx films??

Mickb
Posts: 106
Joined: Sun Dec 22, 2013 8:19 pm
Location: Yorkshire UK

Re: Problems with Streetview on GPS-rides since 15th February

Post by Mickb » Wed Apr 05, 2017 2:46 pm

mcinner wrote:
Wed Apr 05, 2017 1:28 pm
My God, dear me...
What I'm reading here is no good news at all.
At that moment I don't have the guts to risk the upgrade... :oops:
Nothing to fear really. No worse than it was. In fact, for me, 2D is a lot better. Higher zoom on the "Minimal" setting for one thing. Looks like someone has achieved getting "Street View" back so maybe it's going to be one of those annoying issues which affects just some! I would update via the patch download though.
Patdu16 wrote:
Wed Apr 05, 2017 2:01 pm
Hello,

I have not contacted Tacx support, how can i do to got my 2 Tacx films??
By contacting them!

mcinner
Posts: 167
Joined: Fri Nov 20, 2015 10:19 pm

Re: Problems with Streetview on GPS-rides since 15th February

Post by mcinner » Wed Apr 05, 2017 3:01 pm

Ok - I did it!
Updated by using the TTs Launcher - and it works! :D :D
Did a short test and streetview is back.
Seems to be "normal" now, that one can see streetnames and a black-frame-insert between different streetview-pictures.

Will test it intensively very soon.

ttelmah
Posts: 611
Joined: Thu Jul 14, 2011 3:13 pm
Location: UK

Re: Problems with Streetview on GPS-rides since 15th February

Post by ttelmah » Wed Apr 05, 2017 3:48 pm

Ditto.

It's slightly different. The satellite display seems a little better.
The Streetview now does some interpolation between frames, but still has the behaviour of staying in one spot, drawing multiple frames on the same spot, then jumping forwards a huge distance. However at least it is running. :)
I was wanting to 'rehearse' a route so I could ride it without having to carry a GPS or maps, but time is now getting short to remember it all before I have to do it for real. Anyway at least I can run through the main bits....

drewtoncrane
Posts: 37
Joined: Thu Oct 30, 2014 9:49 am

Re: Problems with Streetview on GPS-rides since 15th February

Post by drewtoncrane » Wed Apr 05, 2017 9:22 pm

Just tried my Tacx - thought ".... great stuff .... Street View is working again" - anyway all is OK except mine looks to the left rather than straight ahead!

Nearly there ... did a 19 mile ride / over an hour and there were no crashes or freezing

User avatar
CVOLVO.COM
Posts: 99
Joined: Sun Jun 08, 2014 4:22 pm
Location: Newington, ON, Canada
Contact:

Re: Problems with Streetview on GPS-rides since 15th February

Post by CVOLVO.COM » Thu Apr 06, 2017 1:14 am

I'm glad to report my recovery, back to 4.21.0 FULL, then update to 4.22.3 is now working. I have cycled my reference short ride without any difficulties and both the Google Earth and StreetView are back to normal. I get staggered full refresh screens with almost no transitional blur. The elevation changes seem more gradual too. I'd like to thank TACX and the software support developers for fixing this essential feature (for me) of TTS4.

My next test will be a ride around the lakes of Canberra - much better than the snow and rain in the Canadian forecast.

ttelmah
Posts: 611
Joined: Thu Jul 14, 2011 3:13 pm
Location: UK

Re: Problems with Streetview on GPS-rides since 15th February

Post by ttelmah » Thu Apr 06, 2017 9:11 am

The looking sideways thing has always existed since Earth disappeared, but does seem to be worse.
It seems to relate to 'still images' being present on the Google map at particular locations. So if you are at a spot where such images exist, it starts showing these, without reference to what direction you are actually facing. There ought to be a setting for this in the requests sent by TTS to the Google server, basically saying 'ignore still images'.
In your case, it may be that some new stills have been uploaded, so suddenly you are getting these.
For ages I've had it that whenever I ride past a couple of 'landmarks' on a Streetview ride, it starts showing the pictures of the landmarks, rather than the view ahead along the road.
I just tried a ride round the Isle of Man TT course, and when you get to the pit area, it starts showing 'views' of the pit buildings, rather than the road.
However along some of the normal roads, this doesn't happen. It still though insists on showing several images from the same spot, then jumping forwards quite a distance, rather than progressing along the road.

At least it is working. :)

mcinner
Posts: 167
Joined: Fri Nov 20, 2015 10:19 pm

Re: Problems with Streetview on GPS-rides since 15th February

Post by mcinner » Thu Apr 06, 2017 3:46 pm

I feel sorry for Mickb and hope, his problems will be solved soon... :P

Today I did two for me well known Streetview-GPS-rides. Here are my impressions:
What is different to old Streetview?
Nomore "lost tiles" of previous picures. Always a complete new picture.
Changing pictures now is different: sometimes like "old" Streetview - simply a new picture without flickering. But very often there are "black frame inserts" between the pictures. This is a little irritating because it's a hard contrast change - timeline becomes flickering.
The third kind of picture-changing is a zoom-in into the next picture - that's nice. Zoomed pictures become sharp immediately.
If sometimes there are no Streetview-pics available, the "old" version showed the complete track. Now it is different: you see the track zoomed at the level of the Google-camera-settings.

In my oppinion not more "wrong sideviews" as in the old version.

So, the only thing I do not like are the "black frame inserts".
If it is not possible to show the previous picture until the new one shows up, it might help, if the backgroundcolor of the picturebox which holds the Streetviewpictures is not black but a midtone-grey. Maybe then the flickering is not so hard as with completly black background.

But over all - I'm happy to have Streetview back!

Mickb
Posts: 106
Joined: Sun Dec 22, 2013 8:19 pm
Location: Yorkshire UK

Re: Problems with Streetview on GPS-rides since 15th February

Post by Mickb » Thu Apr 06, 2017 3:56 pm

mcinner wrote:
Thu Apr 06, 2017 3:46 pm
I feel sorry for Mickb and hope, his problems will be solved soon... :P
Appreciated!! :) I am hoping that too. Beginning to think that it's just me who has this issue! I note that my log file has been downloaded by 8 others so hopefully some of the brains on here will be working on it.

User avatar
Lunatix
Site Admin
Posts: 2573
Joined: Thu Dec 06, 2012 3:20 pm

Re: Problems with Streetview on GPS-rides since 15th February

Post by Lunatix » Thu Apr 06, 2017 6:44 pm

mcinner wrote:
Thu Apr 06, 2017 3:46 pm
I feel sorry for Mickb and hope, his problems will be solved soon... :P

Today I did two for me well known Streetview-GPS-rides. Here are my impressions:
What is different to old Streetview?
Nomore "lost tiles" of previous picures. Always a complete new picture.
Changing pictures now is different: sometimes like "old" Streetview - simply a new picture without flickering. But very often there are "black frame inserts" between the pictures. This is a little irritating because it's a hard contrast change - timeline becomes flickering.
The third kind of picture-changing is a zoom-in into the next picture - that's nice. Zoomed pictures become sharp immediately.
If sometimes there are no Streetview-pics available, the "old" version showed the complete track. Now it is different: you see the track zoomed at the level of the Google-camera-settings.

In my oppinion not more "wrong sideviews" as in the old version.

So, the only thing I do not like are the "black frame inserts".
If it is not possible to show the previous picture until the new one shows up, it might help, if the backgroundcolor of the picturebox which holds the Streetviewpictures is not black but a midtone-grey. Maybe then the flickering is not so hard as with completly black background.

But over all - I'm happy to have Streetview back!
We have also noticed the black screen inbetween loads. THis is however not by our doing. This is with the new API of Streetview that this happens. We've had several cases with the same results

Locked

Return to “FAQ - Tacx Trainer Software 4”

Who is online

Users browsing this forum: No registered users and 1 guest