Not recognizing Polar H10 HRM after working fine in the past

Training Zones & other HRM related stuff

Moderators: mcorn, Tacx Moderator, Tacx Video Production, malfukt, Tacx support

Post Reply
Posts: 1
Joined: Fri May 04, 2018 5:48 pm

Not recognizing Polar H10 HRM after working fine in the past

Post by rpalestina » Fri May 04, 2018 5:55 pm

I have successfully paired my Polar H10 HRM to my Tacx app on my iPhone in the past, however, I accidentally X'd out of the Polar H10 on the app when it was recognized, and even though I know the HRM is paired to my phone since it indicates it in my settings,I cannot get the Polar H10 to re-display on the app and as a result, I am unable to get it to connect. I have tried everything from re-installing the app, restarting my iPhone, etc. but nothing seems to work. I also am positive it has nothing to do with the HRM because it pairs fine with other apps on my same phone, and I also make sure it is not paired to any other devices when I attempt to pair it to the Tacx training app. I'm at a loss and am unable to train properly and it's getting a little frustrating, especially since it worked just fine in the past before I accidentally X'd out of it. Any insight would be greatly appreciated!


Post Reply

Return to “Heart rate”

Who is online

Users browsing this forum: No registered users and 1 guest