Incorrect watts reading

Anything about Power (watts)

Moderators: malfukt, Tacx support, mcorn, Tacx Moderator, Tacx Video Production

Post Reply
Rhymer
Posts: 3
Joined: Tue Dec 15, 2015 11:40 pm

Incorrect watts reading

Post by Rhymer » Wed Dec 16, 2015 10:04 am

Hi my Fortius is displaying incorrect wattage readings despite correct calibration ? 120 psi in tyre 3.5 turns from touching tyre to a value of 1-2 , there is resistance going to the brake it does increase when the gradient goes up in catylist and rlv's however the watts displayed on screen seem way to easy to the effort I'm putting in at the pedals ? Display is showing I'm generating 220 watts but I'm not really pushing that feels like 160 watts ?any help appreciated ?

Regards

Gavin.

iofred12
Posts: 3
Joined: Sun Feb 21, 2016 6:59 am

Re: Incorrect watts reading

Post by iofred12 » Sun Feb 21, 2016 10:10 am

Looking at all the threads on this I am amazed at the amount of questions and comments, but the lack of response

Got my unit yesterday but might return it tomorrow

iofred12
Posts: 3
Joined: Sun Feb 21, 2016 6:59 am

Re: Incorrect watts reading

Post by iofred12 » Mon Feb 22, 2016 10:09 pm

I did return it today, but opted to go for the Tacx Neo, now who is the daft one

mimuyayo
Posts: 3
Joined: Tue Oct 04, 2016 7:09 am

Re: Incorrect watts reading

Post by mimuyayo » Tue Oct 04, 2016 7:13 am

no response from Tacx

Post Reply

Return to “Wattage”

Who is online

Users browsing this forum: No registered users and 5 guests