i-Magic / Fortius / TTS4 - confused!

Fortius, i-Magic , Cosmos, Flow , upgrade kits

Moderators: malfukt, Tacx support, mcorn, Tacx Moderator, Nasz, Fortius Magical Man

Post Reply
UnoHoncho
Posts: 1
Joined: Wed Aug 08, 2018 5:06 pm

i-Magic / Fortius / TTS4 - confused!

Post by UnoHoncho » Wed Aug 08, 2018 5:26 pm

Hi

I bought an i-magic trainer 2nd hand and it came with the steering unit and T1932 VR unit but I am having numerous problems and can't get it working

1. I only get an Amber light on the head unit, I've tried unplugging and re-plugging dozens of time but it makes no difference, the drivers seems to be installed as when I go into device manager it shows VR-Interface although this seems to be a generic driver ? I'm running Windows 8.1 64 bit which I know is probably incompatible but I thought the head unit would at least show a data connection between the laptop and itself ?

2. I've got both Fortius and TTS4 installed but neither recognise the trainer, I can't even determine if the trainer is working ok, it doesn't make a noise or beep when I switch the power on so how do I know it is working ?

3. If I got down the VM route and create a 32 bit OS to try and get Fortius to work, how do I manually switch the resistance up and down ? TACX instructions are very poor and don't describe how this can be done, or even if it is possible. Can you manually increase/decrease the resistance on TTS4 ?

4. Can I use the Fortius T1932 VR unit with TTS 4 ? If there is a driver issue, how do I resolve it ?

Any advice ?

Thanks

User avatar
Alex Masalovich
Moderator
Posts: 1676
Joined: Sun Nov 30, 2014 10:17 pm
Contact:

Re: i-Magic / Fortius / TTS4 - confused!

Post by Alex Masalovich » Wed Aug 08, 2018 7:00 pm

Try this if the VR-interface is not recognized in the TTS4:
http://ttsapi.tacx.com/service/analyse/ ... recognized
Тренируйтесь много, отдыхайте ещё больше!

mcorn
Moderator
Posts: 7286
Joined: Fri Nov 24, 2006 8:55 pm
Location: USA, Bellingham, Washington

Re: i-Magic / Fortius / TTS4 - confused!

Post by mcorn » Thu Aug 09, 2018 2:06 am

T'he white with blue ring T1932 controller should work with both the Fortius and Imagic brake on any Windows 7, 8 and 10 64-bit operating system. A 32-bit operating system is only required if you are using an older green Imagic-specific controller.

If you are not getting a flashing green LED on the T1932 then you likely have either a driver issue or a bad T1932.

You did not indicate what version of TTS4 you have installed. You need to have the latest version with all the updates. As I recall, the drivers in the older version may not work properly. The best thing to do is start with the 4.21.0 installer and then apply all the 6 updates after 4.21 without opening the program and without connecting the USB until you are done.

The updates can be found here:

http://patches.tacxdata.com/

There is a link to the complete 4.21.0 installer:

http://tacxdata.com/files/support/TTS_4.21.0_FULL.zip

Post Reply

Return to “Fortius - i-magic - Cosmos”

Who is online

Users browsing this forum: No registered users and 7 guests